GL865 quad and exchanging data with the HTTP server

9 thoughts on “GL865 quad and exchanging data with the HTTP server

  1. Hello,


    I’m working with the GL865 Quad, and I can’t have the HTML code of the page, as it is explain in the IP easy user guide.


    after sending :  AT#SD=1,0,80,""rn , the module respond with connect.


    But after that when I try to send data, it doesn’t work. Here is what I send:








    getchar();  // this fonction not only get a char but get the entire response


    But the module always repsonds with:  Pulsar Core homepage


    What did I do wrong? 

    1. A HTTP request ends with double /r/n not single.


      If you don’t use flow control set AT&K0.


      Don’t rely on only 2 seconds to have the reply.


      1. Thanks for the answer, I just try with an other /r/n like that:







         and I tried to wait 10 and 30 secondes for the answer, and I still have this answer, but now it’s completed with a "NO CARRIER".


        And I set AT&K0 since the beginning.


        before those commands, I set:


        AT+CGATT=1rn                                             ==>  OK

        AT+CGDCONT=1,IP,m2minternetrn             ==> OK

        AT#SCFG=1,1,300,90,600,50rn                    ==> OK

        AT#SGACT=1,1rn                                          ==> IP adress and then OK

        AT#SD=1,0,80,""rn                  ==> CONNECT 






        1. In fact you are getting the server answer, a redirection page. Test with another server or a specific URL, not the root document.

          1. I already tried with "" and the true link of the homepage of telit;  it still answered "NO CARRIER" , even if the beginnning of the answer was not the same.



          2. And what else would expect? "NO CARRIER" means the keep alive option is not supported by the server and the connection is closed by the remote.

          3. But you are saying (and can be seen above, that Pulsar message is part of the returned page) you do receive something between CONNECT and NO CARRIER. Maybe is your code that does not catch the whole return – test with a PC serial terminal software.