GE865: Network issues. Cannot send SMS, cannot receive SMS after power cut.

6 thoughts on “GE865: Network issues. Cannot send SMS, cannot receive SMS after power cut.

  1. Hi,

    We are experiences issues with the GE865-QUAD module not operating properly at all times.
    Software version on GE865 is 10.00.002.
    The problem is the connection to the network, it appears to be fine according to CREG and CSQ values, but no network actions work. Details below. Basically, when it works, it works fine. Cut power to the unit, power up again and nothing works any more. (Send SMS/Receive SMS/make Call)


    Should we “do” something on power up, or should the GE865 automatically handle reattachment to network? 



    Fault description:

    Test setup:a
    1. Power up the unit (with sim card inserted)
    2. Perform power on sequence and check :
    a. CREG Status (0,1)                                                 = Connected to home network
    b. CPIN Status (Check “OK”)                                 = Sim OK.
    c. CSQ Status    (Values are 11-14)                     = Have signal.
    3. Do Read SMS / Try Calling / Try Send SMS.

    Now, the first time everything works just as it should.
    1. Cut power to the unit (I.e. the power feed is cut, and power is cut “directly” to the GE865, no “detach” network can be made)
    2. Power up unit again. Results will be exactly the same for CREG,CPIN and CSQ.
    3. All AT commands still work and GE865 responds “OK”– BUT:
    b. NO SMS IS SENT.
    c. NO CALL CAN BE MADE (Error code: No Carrier)

    Trying to reboot, still the same problem. Take out the SIM card and insert “SOMETIMES” (Very seldom) it starts working.

    1. Take the SIM card out.
    2. Put it in a NOKIA phone,
    3. send an SMS to the number and “all” the pending SMS are received by the phone.
    4. Plug the SIM card back into GE865
    5. Power up the unit
    6. The Ge865 is now able to send AND receive SMS and make calls, until power is cut to the unit again.

    Details on Power On Procedure:

    Power On Sequence: (Same every time)
    1. Unit is powered on.
    2. GE865 is powered up with 3.8Volt
    3. Reset PIN is driven low and reset performed on GE865
    4. Power On/Off to the module is pressed (1 sec)
    5. Unit is checked for “ATr” response “OK”
    6. Init sequence (“AT+CMGF=1r”,”AT#SMSMODE=0r”,”AT+CPMS=”SM”r”), “AT+CSCS=”8859-1″r”)

    Read SMS Sequence:


      1. Hi Cosmin,


        The firmware is indeed 10.00.002 on the module.


        The result when "working" was:

        #SERVINFO: FO: 73,-90, "vodafone SE", "24008", 21, "2BCD"

        CREG =0,1

        CSQ = 0x0D


        The module worked 4 reboots, now in the "non-working" position again. Result is:


        #SERVINFO: FO: 73,-86, "vodafone SE", "24008", 21, "2BCD"

        CREG =0,1

        CSQ = 0x0D


        Doing COPS=2, then COPS=0, same result. Still not receiving or sending SMS/call.

        1. Hi again Cosmin,

          Could this be a problem with the signal quality? We assumed that CREG = 0,1 ment that all service should be available?


          Looking at the SERVINFO, the Signal Strength is around -90dBms. Is there a minimum strength needed to operate i.e. SMS service? Or should CREG = 0,1 mean that it is up and running?


          The telephone company (Telenor/Vodaphone) have checked the logs and according to them, the messages "transmitted" from the unit in "failure state" never reached the telefphone station. So they are guessing it is a signal strength problem.





          1. Is bad but not that bad:


            -105 to -100 = Bad/drop call
            -99 to -90 = Getting bad/signal may break up
            -89 to -80 = OK/shouldn’t have problems, but maybe
            -79 to -65 = Good
            Over -65 = Excellent


            Try a better antenna, maybe a directional high gain one.

  2. We had similar situation when using 10.00.002. Sometimes after powering up GE865-QUAD we were not able to make calls.


    Got this info from Telit support which solved our problem as we are not using gprs:

    Outgoing calls: Use AT#AUTOATT=0 to disable automatic detach then reboot the module (setting is stored in NVM).