GE864 quad v2 – tcp/ip and http problem

One thought on “GE864 quad v2 – tcp/ip and http problem

  1. hi,


    i have designed my own board and it has the telit ge864-quad v2 module on it. (see img309) on my board the module is connected via UART with an ARM7 µC so i cant use hyperterminal or an IDE. my µC has to do the configuring of the module. the UART lines RX,TX,RTS and CTS from the µC are connected with a multiplexer 74HC4052D (see schematic ARM7 screen 1-3 and schematic for ge864 quad v2.pdf) my board has received a design review from telit. so far to my hardware.


    what i first tried was a http GET request to google but it fails (see screenshot 1 & 2) what you see in the screenshots is the UART rx 1 FIFO which holds the responses of the module to my AT commands. i also attached my init function from which you can see which AT commands were send to the module. i dont know why i get this 408 timeout error. 


    the second thing ive tried was a tcp/ip connection to my webserver on which runs a little java test programm. if a client connects to it it prints a "client connected" out on the cmd line and also any raw data send from the client. i first tested it with my desktop pc and a IE browser which means i typed in the  IP address and hit enter and it worked my server recognized it but with ge864 module it doesnt work ALTHOUGH i receive a "CONNECT" after the at#sd command. i also tested my signal strength. i receive a +CSQ: 24,0 which it pretty good according to the manual. im really out of ideas here what could be the problem. first i thought it is because of my mobile phone provider but the microsim card inside a mobile phone works. i have two prepaid cards from two different providers. is it possible that the module doesnt work with a prepaid card? i mean they have different APNs

    i have o2 and vodafone and according to this site (link) prepaid customers have to use a different APN.