Problems with High temperature and TEMPMON

4 thoughts on “Problems with High temperature and TEMPMON

  1. Hello

    I’m using on embedded HW chip Telit HE910 for UMTS communications.

     

    Unfortuantelly while transmitting data the Temperature values are quite high and after i read T near 66-68 degrees i see a freeze of the Telit device.

    Before the crash i see the value:

    AT#TEMPMON=1

    #TEMPMEAS: 1,67

     

    I suppose that the T becomes on 70 C  and it happens a shut-down.

    But i can’t check the values of ttrigger.

     

    How can i use the  TEMPMON to check the upper bound that limits the run ? 

    I want  set it major than 70 or disable this feature.

     

    Could you help me, please ? 

    Thanks 

    Enrico

     

     

    1. To disable the automatic shutdown at extreme temperature reach issue:

      AT#TEMPMON=0,1,0

      But of course the design must be investigated why this happens. 

       

  2. Ok, Thank for the quick answer.

     

    I tried with this command but i see always freeze during the running

    after critical Temp situations.

     

    I activated also the messages to detect warnings

    at+cmee=2

    but i don’t see any Warning about  it.

     

    The FW should print some alert ? How can i check ?

     

    And by the way, what is the command AT to see the upper bound for the T ?

     

    Many Thanks

    Enrico 

    1. Ciao Enrico,

       

      you can’t set teh temperature threshold, but just enable or disable the functionality of TEMPMON.

      CMEE allow to display the error message code as a result of un supported AT commands or wrong parameters. It doesn’t allow to get messages from TEMPMON. 

       To get it you use theTEMPMON parameters to set allarm as an URC or a GPIO rising.