SE867-AGPS Issue – Standard NMEA sentences are blank

8 thoughts on “SE867-AGPS Issue – Standard NMEA sentences are blank

  1. Hi,

    We are using GE865 and SE867 module. GE865 ASC1(SER2) is connected to SE867 module. After switching on the module it starts straming standard NMEA sentences on the auxiliary UART. The streaming sentences does not contain any location information.

    For example :

    $GPGGA,001335.000,,,,,0,00,,,,,,,*7C

    $GPGSA,A,1,,,,,,,,,,,,,,,*1E

    $GPRMC,001335.000,V,,,,,,,,,,N*49

    $GPGSV,1,1,00,,,,*79

    What might be the problem due to which standard NMEA sentences does not contain any location information?

    1. Looks like your SE867 has no signal because of an antenna problem or no sky view. And leave it some minutes after switching on, 5-10 minutes, if is the first start it will take time to acquire signal.

       

      1. Could you please elaborate more on "no signal because of an antenna problem" and "no sky view".

        After switching on we waited more then 10 minutes to retrieve information from GPS but still it was giving blank details.

        Will AGPS help in this issue?

        If yes along with time server and agps server what are the details required to download file.

        And who provides time and agps server details is it Telit or operator?

        1. Could you please elaborate more on "no signal because of an antenna problem" and "no sky view".

          To be honest I don’t know how to explain in a better English – check the antenna and signal path, bring the module in a place with clear sky above, no buildings, trees etc.

          1. Hi,

            GPS is working fine on our SE865-AGPS evaluation board. GPS is not working on custom host board.

            Is it possible for Telit to provide us details of Time server and AGPS server so that we can make AGPS work on SE867-AGPS evaluation board first and then on our host device.

            SE867-AGPS evaluation board documentation does not contain information about activating and using AGPS on itself. If there is any other document explaining the same please provide us for reference.

            Thanks.

          2. Hi Cosmin,

            We did as you suggested.

            We took the module on our office building roof. After we reset the module waited for more then 10 minuts so that module can locate itself and provide location information.

            We got the same result as mentioned earlier.

            All the NMEA sentences were blank and no location information was obtained from the module.

            $GPGGA,001335.000,,,,,0,00,,,,,,,*7C

            $GPGSA,A,1,,,,,,,,,,,,,,,*1E

            $GPRMC,001335.000,V,,,,,,,,,,N*49

            $GPGSV,1,1,00,,,,*79

            There was only information about time and no satellites located.

             

            If satellites are not found then how is the module relaying NMEA sentences ?

            What are we missing here ?

             

            Regards.

          3. If the evaluation board is working and your board is not I can suspect a hardware problem, did you check everything? Especially antenna and antenna path?