FTP append problems

9 thoughts on “FTP append problems

  1. Hi all, trying to append data to an existing file over FTP.
    But at#ftpapp command is not accepted at all. Tried all
    varieties, please see below (comments added behind #):

    at#ftpfsize="MSG.txt"     #File to be appended really does exist
    #FTPFSIZE: 10

    at#ftpapp="MSG.txt"       #No connMode specified
    at#ftpapp="MSG.txt",0    #Set connMode to 0
    at#ftpapp="MSG.txt",1    #Try connMode = 1
    at#ftpget="MSG.txt"        #Get the file
    abcdefghij                       #Here you see the present contents

    When listing the directory where the file to be appended is
    located, I get as follows:


    -rw-r–r–   1 zusernamehere psacln         10 Mar 15 16:14 MSG.txt


    What are meanings for the fields "-rw-r–r– " and "psacln"? Maybe
    the permissions are set wrongly at the server end, for an append

    to be possible?


    However, I can remotely create new files on the server, using


    So what might be the reason for append not working?

    1. Hi Tom,


      What firmware version is on your module?

      Indeed these are permissions and "pslacln" is an user group used by Plesk, a common server administration panel. Don’t know more though – try to give everyone access to write in that file.



      1. I knew you would ask. So I just updated 😀


        It was:



        Now is:




        Should be the latest firmware? And what I report here was happening AFTER the update.


        I have also placed a question with my ISP, but no answer yet. BTW, is there a way to debug deeper, ie. what really happens when I try to append something over FTP?

        1. Yes that is the latest; please check the permissions on that file, you can do this I think in your hosting control panel or with a nice FTP client like Cyberduck.

          1. Cosmin, I managed to tweak the settings of this file in question, by using the Control Panel that my ISP is providing. Now I have ticked all viewable "write" permissions into ON state. But the problem still persists. The command at#ftpapp (in all variations) is always responded by ERROR.


            What to do next? And is there some prerequisite to issuing the command at#ftpappother than just opening the FTP connection, and changing the directory to the correct one, where my file is located?

  2. Thanks for this "trick"! Indeed, it shows, like here:


    #FTPMSG: 451 MPG.txt: Append/Restart not permitted, try again


    But I have now set ON all possible switches I can see on my ISP’s Control Panel.


    1. I suppose is a server setting item, google for "Append/Restart not permitted, try again" and check in your cpanel if you can find the switch.

      1. Finally, problem solved. My ISP confessed that appending was prohibited all over my tiny FTP server that they operate. Something I could not possibly change myself but they had to do it with their privileges.


        Good to know for the future. Everything had worked for quite a time, but sofar I was only creating new files, not appending to old ones. So I could not imagine…


        Thanks for your support!