Freeware FTP server data logging problem

4 thoughts on “Freeware FTP server data logging problem

  1. Hi,

    I am using Telit GL865Dual v3 modem. I am using our company’s simple ftp server for data logging purpose; and everything works fine here.

    (Note: Simple FTP server means no secure connection like SSH/SSL etc.)

    Now at our client side, they have their own simple ftp server (purchased from GoDaddy). The same data logging module doesn’t work properly there. The problems are:

    1. Module gets connected to client’s ftp server using cmd “AT#FTPOPEN”

    2. It will create blank ftp file using command “AT#FTPAPP=’filename’, 0” in online mode

    3. it is giving error: +cme error:606 (i.e. bad or no response from server) in response of at command “AT#FTPAPP”

    4. Then after it is not writing any data in that file.

    5. I have tried to upload one file from my local PC to client’s ftp server using “CuteFTP” software and it works fine.

    above mentioned same program works with our compan’s ftp server… so what is the problem with clien’s ftp server?

    I have notice one thing that modem uploads data to some specific authenticate ftp server only. When I tried to upload data to local ftp server

    (like Filezilla server application which is freeware software), it gives cme error 606 every time.

    So could you guide me what should be the server specification while accessing it through modem for data logging?

    Should I need firmware update of telit modem? If required then how do I upgrade it?

    Any help is appriciable…

    1. Check the <mode> parameter in AT#FTPOPEN maybe the server does not support what you are using, or not set to.

      1. Thank you COSMIN for reply.

        I have checked with both mode = 0(active) and mode =1(passive). But still no result. Data is not logging to ftp file.

        1. Hi,
          this issue should be firewall related.
          Since the module can create a file on the FTP server, but cannot upload the content, it should mean that ftp-data traffic does not go through.

          In this case, the firewall that blocks ftp-data traffic should be in the mobile network operator’s network (in front of the module).
          However, it should work in PASSIVE MODE, but the FTP server and the firewall in front of the server must be configured correctly.