Firmware update problem

8 thoughts on “Firmware update problem

  1. Hello,

    I’m using a GL865-QUAD device, and I tried to update its firmware but I accidentally used the firmware streamGL865-DUAL-10.01.151.bin – when I made this attempt an error window showed at the end of the update. I then realised I was using the wrong version, and so I tried to update the firmware for streamGL865-QUAD-10.01.141.bin, but now I only get the error -4 “boot timeout”. What should I do now? I thought that the xpf tool would rewrite the whole ROM with the correct firmware version.



    1. If things aren’t terrible wrong the XFP should do the job. Have you tried with another PC?

      1. I just tried again on my PC. It showed the following message:

        Error: -Error rx (0x000001EE – 0x000101ED), Code -52(code: -9).

        I can try later on another PC, but do you have any advice about this error code?

        1. Hi Denis,

          can you please try to set on xfp.ini file (it is inside the xfp folder) a debug flag as below and share here or via mail to the file you will see in the same xfp folder?




  2. GE865-QUAD Firmware Update


    I’m having problems when I’m trying to reflash a GE865-QUAD that is already with 10.00.008 firmware.

    My Operating System is Window 10,  XFP ver

    Following the advice from another thread, I’ve enabled the Debug=2 flag on Xfp.ini, and now it creates a file named trace_xxx.txt

    I’m not having problems with another device with 10.00.007 firmware, I can even flash older versions on it, like 10.00.005.

    I hope the trace file helps to understand what is happening.

      1. Hi Luca

        I’m trying to reflash the module with 10.00.008 to 10.00.007. Actually, I’ve also tried to reflash it to the same version, 10.00.008, without success.

        With another module, which I’ve never flashed a version above 10.00.007, I can reflash it to any version since 10.00.003.