Firmware programming problems

7 thoughts on “Firmware programming problems


    I try to update the firmware of our embedded GE865-Quad to 
    10.00.004. I´m using Xfp 2.0.13 and it starts with programming. 

     Programming stops with “Error: flashSendStream – Error rx (0x000001EE – 0x000101ED), Code: 114 (code:-9)”

    What does this mean?

    I´m using a seria-to-USB adapter @ 115200 Baud.

    1. Maybe is a driver problem, try to update with the latest. A lower baudrate won’t work as well? Is the adapter working well otherwise?


      1. The adapter is working well in other cases.
        I tried lower baud rates – but I get the same error message all the time.

        1. Please use a freeware serial sniffer (e.g. Portmon) to get a log of what is happening during this operation and then post it

  2. I managed to update one device by directly soldering the USB adapter to the RX/TX pins and bypassing the MUX and level shifter.


    We have to update 80 devices in the field. The only practical way to do this seems to be to update the firmware using our application processor that talks to the GE865. (Update without the Xfp software.)

    Is there any documenation of the update protocol?


    Thank you!

    1. There are no public specifications, and the only successful trial to use an intermediary bridge between PC and module that I am aware was using a fast interrupt driven level change bridge/mirror, all attempt to mirror RS232 traffic failed. Maybe you can implement the first one too.