Strange voice message after ATH command

7 thoughts on “Strange voice message after ATH command

  1. I have issues with 2 Polish operators: Orange and Play.
     
    When I call (voice from another phone) my Telit device, get RING signal and issue ATH command I usually get normal message on calling side: “Subsriber is busy” or normal busy signal, but when I call from phone with SIM card from Orange or Play there is normal RING signal but I get strange message on calling side after ATH command: “Sorry, we can not realize this call”. 
     
    Note that this problem does not occur with Plus GSM SIM card equipped caller. 
     
    I tested it with firmware 10.x and 7.x on different modules with same results.
     
    This is quite big problem beacuse in my application I issue ATH immediately after RING singal so caller don’t know if signal succeeded.
     
    It seems that  disconnection using ATH command on Telit module is of different type to standard one used in other devices.
     
    How I can resolve this problem? Maybe there is possibility to alter ATH command, so it would be disconnect incoming calls with standard message. 
    1. Maybe that is the way the networks themselves handle the hang-up. Do you get other results if you call from a normal phone to other normal phone, with these SIM/operators?

       

      Check if AT+CSNS is set to 0 (voice), and the type of your numbering scheme, single or multi. 

      1. Maybe that is the way the networks themselves handle the hang-up. Do you get other results if you call from a normal phone to other normal phone, with these SIM/operators?

        Yes, when I call from a normal phone to other normal phone, with these SIM/operators I get other results – I get standard "busy" voice message and/or signal.

         

        Check if AT+CSNS is set to 0 (voice), and the type of your numbering scheme, single or multi.  

         
         AT+CSNS is set to 0.
         
        I am not sure what do you mean by "single or multi numbering scheme". Incoming calls are indicated to be in national numbering scheme (129)
          1. There is no difference if I wait 1 or 10 RINGs.

             

            When I answer the call (using ATA command), and then issue ATH everything is fine.

            The problem occurs whenever I reject the call from phone with one of these SIM providers.

             

            However Plus GSM SIM provider clients work fine. So i suspect that Orange and Play use something like "Extended ATH" and it does not work well with Telit ATH execution. 

  2. When I put Orange (PL) SIM card in Telit and call using ANY phone and ANY SIM Card (Plus, Orange, T-Mobile, Play, etc) I ALWAYS get this error message after ATH command.