Delete non py, pyo file

8 thoughts on “Delete non py, pyo file

  1. I have been trying and trying to figure out how to delete a file from a Telit GE865Quad that doesn’t end in py or pyo. I have a file that ends with "text.txt" and when I use AT#DSCRIPT ="text.txt" I am getting "+CME ERROR: memory failure".


    Any ideas? 

    1. That should work, please report firmware version (AT+CGMR). Maybe the memory is corrupted in some way (is this a file that be left open at a shutdown, reset or such)? Do a fresh firmware upload, then try with a txt file upload with WSCRIPT and delete it.

      1. Thanks for the response.


        I checked the firmware and it is 10.00.002. I see the most recent is 10.00.004. I downloaded Xfp 2.0.13, and it will get to the "Programming…" state. It doesn’t complete that state, but instead ends with the following "Error: FlashSendStream – Error rx (0x000001EE – 0x000101ED), Code: 114 (code:-9)" 


        Since updating the firmware didn’t work, I tried to overwrite the file using AT#WSCRIPT="text.txt",18,0. That is the filename of the existing file and the size. I then sent it a couple words to fill the 18 bytes. The new text.txt was readable using AT#RSCRIPT (the previous one was not). I did AT#DSCRIPT="text.txt" and it returned OK, but AT#LSCRIPT still shows "text.txt", 18. Subsequent attempts to run AT#DSCRIPT="text.txt" return the same error, "+CME ERROR: memory failure". 


  2. I tried the same and all went smooth, uploading and deleting 18 bytes txt file.

    Try to solve firmware uploading, download the files again from Download Zone, try even with the old 10.00.002, to have at least a fresh module. Is it a real serial port or USB to RS232 adapter?


    1. I tried it on another module I have and it went fine. Guess there is something wrong with the dev board. Thanks for the help. 

  3. How can i find the existance of a file in Easyscript.


    Actually i am trying to open a file named  data.txt.

    Some cases if the file doesn’t available in the NVM of GL865QUAD, I like to create a new file with default values.


    Can you help me out to solve this issue?


    Thank you 

    1. You can do it with AT#LSCRIPT or


         # do something
      except IOError:
         # create and fill file


      1. f = open(‘data.txt’,’w’)                      # open data.txt file for writing (if exists will be overwritten)

        f.write(‘string’ + ‘rn’)          # ‘rn’ termination is to ensure that every string will be at separate row