DE910 GPS cannot get NMEA stream

3 thoughts on “DE910 GPS cannot get NMEA stream

  1. Hello

    Trying to get the NMEA string, the following is the output:



    +CREG: 0,1















    Then I wait for a long time and nothing happens. Verizon is the carrier

    1. Hi Timofey,


      Which interface are you sending AT CMDs on?  Serial UART or one of the USB ports (“Telit High Speed USB Modem” or “Telit Auxiliary Port”)? 


      With the setting of the first parameter of the $GPSNMUN command being “1” the NMEA stream will be displayed on the “Telit NMEA Port”  via USB connection to the module.  You can use the $GPSACP command to query the last fix details while using your current interface or you can change the first parameter to a “3” to have the NMEA stream displayed on the serial UART.




      1. Hi Matthew,

        I have a similar issue to Timothy.

        Last year I developed embedded code for a system containing the HE910DG module. That code uses GPSACP to obtain location data, but prior to obtaining a fix GPSNMUN=1,0,0,0,1,0,0 is used to get the GPSGSV sentence (satellites in view) data. This allows me to see the satellites in view before GPSACP reports anything, which is useful in our production line tester as it can verify operation more quickly.

        When I try to do the same thing with a DE910-DUAL CDMA module I am unable to get NMEA output. If I change the enable from 1 to 3 as you suggested to Timothy (GPSNMUN=3,0,0,0,1,0,0) the NMEA data appears, but it is formatted differently (no GPSNMUN header) and requires +++ to return to command mode. I agree this is as described in the AT command manual but why is it different to the HE910DG which works just fine with enable = 1 (GPSNMUN=1,0,0,0,1,0,0) while remaining in command mode.

        In both cases I am communicating with the module on the main RS232 port, not USB.

        I have looked at all the documentation I can locate for the DE910-DUAL, searched the Internet for comments or workarounds and tried to make the HE910 code work on the DE910 but to no avail. I’ve even tried the commands documented as “no effect, for backward compatibility”.

        Is there any way to get the DE910 NMEA data to appear on the main RS232 port formatted as per the HE910DG? Apart from carrier support for things like the Sprint HFA process I would not expect substantially different code to be necessary as Telit makes a big point of the modules being interchangeable; that said, there are a number of command and response format differences between the two, most of which appear to be trivial to correct.

        The DE910-DUAL modules I am developing with are for use in the USA on the Sprint network.

        Examples (command [response]):
          [$GPSNMUN: $GPGSV,3,1,09,06,00,000,31,16,00,000,00,17,00,000,00,18,00,000,00*7E]


        Firmware versions:
        HE910-DG:     12.00.004
        DE910-DUAL: 15.00.005

        FWIW I am finding the preview was rendering these examples differently to that shown in the final post. I’m using Firefox. I’ve had to place them on separate lines to prevent them wrapping mid-line.