3 thoughts on “CSURV

  1. Hello, 


    I have two GM862-QUAD devices with fw: 7.02.606, one is working correctly, the other one is unable to register, giving response +CREG: 0,3 (registration denied). In both of them has been the same SIM card, so it is probably not a SIM problem…

    I have performed AT#CSURV on both of the devices. Attached are files with result of the CSURV on working and non-working device. Mobile country code for this card should be 240 and mobile network code 01 

    From the  CSURV I can see that the working gets CELL_SUITABLE, while the non-working has always CELL_OTHER as cell status for relevant cells. 


    Thanks for the help 

    I have just tried AT#SERVINFO for both modems and here is the output
    #SERVINFO: 107,-72,"TELIA S","24001",30,1F50,00,0
    #SERVINFO: 65,-48,"vodafone SE","24008",45,2B5C
    again both of them with the same SIM card and antenna, I have also tried with SELINT 1 and SELINT 2 (in before I had a problem when it was working only with SELINT 1), also changing #REGMODE to 1 did not helped either.. 
  2. Issuing the command at+cops=0 prior registraton solved the problem. For some reason vodafone network has been selected (should be telia) and that caused the registration denied.