Connection drops

25 thoughts on “Connection drops

  1. We have a problem with some of our trackers in the field.
    We have two types of boards, essentially the same, one using the GE864 QUAD, the other using the GE865 QUAD.
    We use a variety of SIMs however I’ll only consider two, both provided by the same comapny whose private APN we use.
    The software on the two boards is identical. Furthermore, the software does not test for the Telit module type or firmware, so the commands issued are the same on the two boards.

      GE864  GE865
    EE  Good  Bad
    Vodafone Good  Good

    By Good, I mean that the GPRS connection can be held up to 24 hours. A self imposed limit
    By Bad, I mean that the GPRS connection is never held for more than 90 minutes, and when the tracker is moving, the connection is often lost after 2-3 minutes.

    On my desk, I see the GE865 with EE Sim disconnecting after 90 minutes.

    To further investigate, I have recently bought a GE865 QUAD daughter board for the EVK2. This way I can remove the possibility of software errors on the product.

    Using the EVK2 GE865 I find the situation is the same as for our product.

    With the EVK2 GE864 I reliably get multi hour connections with either SIM.

    Looking at the logs from the APM provider, when the modem reports NO CARRIER, the logs report that the SIM is still connected.

    Here is a redacted list of the AT commands sent to the modem:


    Looking forward to your comments.

    1. Hi Steve,

      You are using at commands very old you try in this way with GE865:

      1. Hi Cosmin, this does not seem to set the socket timeout. Does #SKTTO still work in conjunction with these commands, or would I have to use #SCFG, in which case, where would it go in the list?

        1. Use the commands grouped under “Multisocket AT commands”, ie you’ll use #SCFG*, before opening the socket with #SD.

          1. Tried the following set of commands:


            Using EE SIM and the EVK2 with GE865-QUAD stationary:

            Three attempts where the connection was dropped by the modem after 88 to 90 minutes. No change.

            Using EE SIM and the EVK2 with GE864-QUAD stationary

            Two attempts where the connection lasted for 120 minutes or more. I terminated the connections. No change.

            Using Vodafone SIM from the same supplier/same APN as EE SIM statioany:

            Over 120 minutes connection with GE864-QUAD and GE865-QUAD.

            So the situation is unchanged in the stationay case.

          2. I have now tried the above using an EE Sim from a different supplier with the same results in the stationary case:

            With the GE864 I get over two hours of connection before I closed the connection myself.

            With the GE865 I only get 88 – 90 minues before the connection is closed.

            I have tried other SIMs from 02 and Vodafone without any problems either on my desk in EVK2, or in vehicles in our hardware.

            I can live with 90 minute max connection time, but when the vehicle is moving I’m only getting very short connection times with the EE SIM in GE865.

          3. Hi Steve,

            I need that you set the command at+cgerep=2,1 so you will receive the unsolicited message that indicate the kind of detach.
            When you will receive the detach I need that you send the command at#ceer with this command you receive the TA report.
          4. I ran it again.

            After 88 – 90 minutes…

            +CGEV: NW DEACT IP, “”, 1

            #CEER: 229

            #CEERNET: 112

            #SLASTCLOSURE: 1,4

            I notice that 112 is not listed in AT commands ref r22

            I have been running today with 10.01.001 with no change over 10.00.003

          5. Hi Cosmin,

            How can it be a network problem if I do not get the same effect using the same SIM with a GE864-QUAD?

          6. EVK2 GE865-QUAD 10.01.002

            09:03 Connected. Supplier shows data session starts 09:03:06


            +CGEV: NW DEACT IP, “”, 1

            #CEER: 229

            #CEERNET: 0

            #SLASTCLOSURE: 1,4

            10:39 Supplier shows data session still open. Last data sent 10:21:39



            +CEGV: ME DETACH

            Supplier shows data session ends 10:41:18

          7. HI Steve,

            In this case to understand the problem the only solution is that you make a trace I need that you enable the template TCP/IP in the link below you can download the trace tool “RTD” and relative user guide.

            Please email directly to, reffer this thread and F. Bernardi.
          8. what we can see is that after a periodic routing area update, PDP context is first resumed and then deactivated by the network. We are still investigating on this.

            You said that GE864-QUAD works ok, but we never asked you which GE864 version you have since there are at least 2 different HW & SW versions. Please let me know.

          9. Tested with firmware version 07.03.000

            Please tell me how to identifiy the hardware versiuon

          10. You asked (by email) for a repeat trace with Dump message hex content checked.

            I have replied with the trace.