AT#HTTPSND unusual reply

6 thoughts on “AT#HTTPSND unusual reply

  1. I’ve LE910-EUG that communicates with a HTTP web service successfully but sometimes when the microcontroller sends the AT#HTTPSND command to the module, the module returns OK directly, if I ignored it and resend again the command, the module returns to me half the command string and stops accept AT commands, then I tried to wait for 1 second then resend again, the module returns a strange character over the PC terminal and stops receive AT commands. 

    How can overcome this step without restarting the modula via unconditional shutdown pin? 

  2. What I do is sending the following command:

    AT#HTTPSND=0,0,”IP Address”,96

    then waits the “>>>” to start sending command, sometimes the module returns “OK” directly instead of “>>>” or “NO CARRIER” or “HTTPRING”

    Is there any possibility that the module can send OK directly, is it a network error or AT controller error or something?

    The strange character is “ÿÿ” it looks like the module is restarted! In the terminal these strange characters appears like double F “FF” under them a star

  3. some of my log and I retry to transmit data after 5 seconds from sending me “OK” response:

    $GPSACP: 080653.000,3000.7896N,03127.7071E,500.0,-2255.8,3,92.1,3.5,1.9,080316,0
    #HTTPRING: 0,200,”text/xml; charset=utf-8″,95                                   
    $GPSACP: 080657.000,3000.9460N,03126.0774E,500.0,439.5,3,61.7,2.6,1.4,080316,02

    1. Hello Ahmed,

      1. Did you set parameters in AT#HTTPCFG?

      2. Please explain where is the data you are sending to the server.

      3. Can I use your server address for tests?

      4. please provide AT+CGMR and AT+CGSN info.

  4. Hello,

    I’m sorry for late response, Yes I did the HTTPCFG correctly as it was working but now I moved to UDP over socket, that’s how I solved the system problem and it’s working.