15 thoughts on “AT+CREG

  1. Hi,
    I have a situation where sometimes (maybe due to network operator problem) modem loses network registration and is reporting +CREG 0,0 ever since.
    Restarting the modem helped but I would like to ask whether there is any other way to get from this "not registered, not searching" state and why does it go into this state in the first place.
    Thanks for the help
      1. Should I do it when I detect this situation? Or during every intialization? Currently I am issuing AT+COPS=0, but I will try also you seconds suggestion, can you explain why to send them in this sequence?


          1. If I use sequence AT+COPS=2, then AT+COPS=0 it gets stuck on different behaviour – for 15 seconds there is a response +CREG: 0,2, followed by +CREG: 0,3 (this is aprox. 4 seconds) and then again +CREG: 0,2 for 15 sec… 

          2. AT+COPS=2, then AT+COPS=0 are used just to re-activate network registration without waiting internal timeouts for that.


            +CREG: 0,3 means that registration is denied. Check again with anither SIM card and consider possible network overloading.

  2. I have tried with multiple SIMs and it was behaving prety much the same…

    Just to make sure… when should those commands be issued? I have tried them just after SIM initialization and afterwards started checking with AT+CREG.

    Also after those commands were removed the modem is able to register again, however if this was caused by overloaded network it may have been an coincidence.. 

    Can this be caused by modem restarting and trying to register to network too often? 
    1. After power you have to send CREG and if the result is 0,0 or 0,3 or 0,4 to send these two commands. If you cycle power on/off too often is possible to be rejected from network. Check signal level with AT#MONI=7 and MONI. What is your module?

        1. Nikolay said:


          Btw, on my avatar picture you can see flying Griffon Vulture (Gyps
          fulvus) marked K02 that is equipped with GPS/GPRS tracker with
          GE865-QUAD inside. It is sending locations to FTP server. Still is in


          See in the thread Product specific > GE863-QUAD/PY/GPS > [F A Q] Transmission of DTMF tones.


          Very very interesting and great engineering achievement. Nikolay, how’s going?

          1. Thanks Cosmin, and Merry Christmas to you and all Forum Members!


            (Would be nice to install such a gadget on St. Claus´s reindeers as well…)

  3. Happy New Year!!!

    Tom, I am not familiar with wild birds, but it seems to be some kind of hawk or falcon.

    The device is BT-28 – Bird Tracker – 28 grams. It is smaller version of initial bird tracker that is described in Telit2Market issue 06/11, p.48/49.


    Cosmin, I continue with development of GSM (and GPS) communication and tracking devices for birds, hunting dogs, wild mamals, for personal tracking, vehicle and asset tracking.


    Btw, it was discovered that GE865-QUAD is working normal from 5V supply. It was my mistake by connecting 3 x AA LiFeS2 batteries that have voltage over 1,5V. So, my question is what is max. input supply voltage for internal supply circuit. I do not like to put voltage regulator.