AT+CCLK operation

9 thoughts on “AT+CCLK operation

  1. Hi all


    I use AT+CCLK? command to get the current date and time from the GSM network, using  GE865. It usually works OK, but after a cold start it often returns a meaningless date of 00/01/01, and time 00:00:xx.


    After some time it however "jumps" to correct date and time. Is there a way to expedite the process of getting the correct time, or is there some known delay after which the time should be OK? In the latter case I could insert a delay in the Python program to ensure the date and time has "stabilized" after network registration.


    Another thing: is anyone using some commonly available Time Server where one could get e.g. the UTC time, using FTP transfer or some other means? If yes, could you please tell the IP address of some server like this?





      1. Thanks Cosmin for these hints.  Is there perhaps an example somewhere about how to use the ntp servers from a GE865, with some piece of Python code?



  2. Hello,

    i’m facing a problem with AT#NTP command: i can see that it doesn’t work while the CMUX is activated.

    In particular I get the following response when i issue the at command:


    SRING: 2,48,…(series of not printable bytes)

    Of course, the internal Telit RTC clock is not updated.

    If CMUX is not activated the NTP sync works.

    Module: GL865-DUAL-V3

    Fw Version: 16.01.151

    Thanks in advance for your support

    Ivan Gaglioti

    1. Dear Ivan,

      I’m trying to reproduce the same error but I cannot see any particular issue with CMUX enable.

      I tried sending the AT#NTP on all the 3 virtual ports.



      #NTP: 15/07/06,15:30:48

      Please set AT+CMEE=2 and repeat the test.

      1. Thanks Andrea for the fast reply.

        I just tried with AT+CMEE = 2, here what i get:

        +CME ERROR: tx error

        SRING: 2,48,$ëCTDÙE$—ðã-ÙE$ W0NÙE$ W›Ç

        The context is open.

        Any idea?

        1. Hi,

          here again with a news:

          i flashed again the latest fw and at#ntp command works, with or without cmux.

          What could it happen?

          I’ll continue to “stress” the module wiht frequent ntp requests in order to check whether the issue would appear again.