Default Sample Application Output

12 thoughts on “Default Sample Application Output

  1. I followed the steps for the default application, with no changes and I get the following output

    [Searching Telit Module]
    * * *
    [COM4 Connected]

    [Remembering “m2mapz.bin” as a last file for a launch button]
    [Upload completed: C:ProgramDataTelitworkspacePlaygroundm2mapz.bin]
    [Directory changed -> MOD]
    [File m2mapz.bin: execute permissions set]
    [Application Started]

    and that is it, where is the uart it is supposed to be displaying the output to ? I tried COM1,COM3,COM5,COM6.

      1. That is what I would have thought but you can see from the output that the ADE is connected to COM4 and all I get is [Application Started] and none of the expected output from the sample application. Completely confused, I would think that the sample app should just work. Not sure what I am doing wrong ….

          1. AppZone C runs the application using AT+M2M=4,10 command, that is supposet to start the application after 10 seconds, if no AT command is received during such time. i have the same issue with this mode, since application runs random and i’d like to know why! i solved manually start the application using AT+M2M=4,1 command.


            problem: if the application uses COM port as a console (UARTtoServer), after it’s started you can no longer send AT commands to control the modem so be careful.

          2. means that sometimes runs (rarely) and sometimes doesn’t, even providing manual AT+M2M=4,10 then it’s not a matter of ADE, that is version 3.0.2. by the way

            i must say on current board only modem USIF0 is connected, but it’s shared between a microcontroller and a PC through RS232 to USB cable and i’m driving the it using the second. i don’t see any AT command sent after reboot though, then the script should start after 10 seconds right?

          3. Hello,

            Are you using the UART default application? Is your usb-to-uart converter providing flow control signals? Could it be your microcontroller forcing the DTR (or RTS) signal low? this could explain the application not starting, because the application blocks when opening the UART. Is it possible for you to try disconnecting the external micro and see if this changes the outcome?

            If AT+M2M=4,10 seems not to work, please try rebooting manually the module (moreover, the minimum value for the timeout parameter is 10, so AT+M2M=4,1 will wait for 10 seconds in any case)

    1. I think I have the same issue.

      I’m using a Telit HE910-NAG in Gatetel’s SWH board, upgraded with firmware “stream_HE910_NAG-12.00.318.bin” to ‘C’ compatibility .  It shows up as ports COM19 through COM24, with AT commands recognized on ports COM1(RS232), COM20(Telit Mobile Highspeed Modem) and COM22(USB3)

      Compiling the default HelloWorld (serial template) application in ‘C’ Appzone 3.0.2 using GCC ARMv6 4.9.3 and uploading via USB:

      [COM20 Connected]
      [Remembering “m2mapz.bin” as a last file for a launch button]
      [Upload completed: C:RubiconTelitWorkspaceHWorldSerm2mapz.bin]
      [Directory changed -> MOD]
      [File m2mapz.bin: execute permissions set]
      [Application Started]


      On the serial port all I see is:

      #STN: 5,0008


      #STN: 1,1

      Compiling the USB template hello world example and downloading over RS232, then using Tera Term to monitor all the USB ports, I do see COM20 disconnect, and on reconnecting I see the correct output:

      87. Hello World!

      88. Hello World!

      89. Hello World!


      So it looks like the serial port example is not complete, but the USB one works.

      1. Hello Andrew,

        I’ll run some tests but my guess is that you’re only using Tx and Rx signals of the RS232

        By default, AppZone needs hardware flow control (unless you disable it). If that’s the case, I’ll try replicating your problem and then I’ll show you how to instruct AppZone to work without flow control


      2. in M2M_Proc(), under

        global_uart = m2m_hw_uart_open();

        put the following code:

        M2M_T_HW_UART_IO_HW_OPTIONS myOptions;
        m2m_hw_uart_ioctl(global_uart, M2M_HW_UART_IO_HW_OPTIONS_GET, (INT32) &myOptions);
        myOptions.flow_ctrl = 0;
        m2m_hw_uart_ioctl(global_uart, M2M_HW_UART_IO_HW_OPTIONS_SET, (INT32) &myOptions);

        This way it should print on the serial console. Be sure to match the baudrate. Default is 115200, if you want to change it assign

        myOptions.baudrate = yourBaudRate;


  2. Also, when using the USB Hello World, change USB_CH_AUTO to USB_CH0 or 1-2-3 because otherwise you’re never sure about where the output is sent to (it’s the first available port)